
UNIT

Unit Exercises:

Advanced Access 2010: 
Advanced Databases

EXERCISE 1
Define Data Needs

EXERCISE 2
Define Field Data Types

EXERCISE 3
Modify Field Properties

EXERCISE 4
Set Validation Rules

EXERCISE 5
Define and Modify Primary 
Keys

EXERCISE 6
Define and Modify Multi-
Field Primary Keys

EXERCISE 7
Define Tables in Databases

EXERCISE 8
Create Tables Based on the 
Structure of Other Tables

EXERCISE 9
Create and Modify Queries

EXERCISE 10
Open Databases

EXERCISE 11
Format and Modify a Chart

EXERCISE 12
Import and Export Data

EXERCISE 13
Set Printing Options

EXERCISE 14
View Code and Convert 
Macros to Visual Basic

EXERCISE 15
Modify Forms and Reports

A database is an organized collection of information. You may be using 

databases every day without realizing it. For example, personal music play-

ers, such as iPods, organize thousands of music, photo, and video fi les by 

title, artist, year, and more. The best thing about databases is that they 

make it easy to search for information using different criteria saving time 

and effort. What other common databases might you use daily?

Why It Matters
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Step-By-Step EXERCISE 1-1
Defi ne Data Needs
When you begin to design a database, you should think about the types of data that 

you need to include. One way to prepare data for use in a database is to create a table 

for your data fi elds in a spreadsheet program such as Microsoft Excel. When entering 

data in an Access database, consider whether the data should be calculated by the 

database or entered by the user. Stored data will remain the same until the user 

manually changes it. Calculated data changes in response to other data modifi cations. 

Examples of stored data and calculated data are shown in Table 1.1.

TABLE 1.1 Examples of stored data fields and calculated data fields

Stored Data Calculated Data

Product ID Total value of all products in inventory.

Product name Total number of products in inventory.

Product cost
Total Value is calculated by multiplying the Product cost fi eld by the 
Inventory fi eld. 

Inventory Average monthly inventory levels.

FIGURE 1.1 Product Info worksheet

Examples of fields 
with stored data

Field with 
calculated data

Records

If a database stores cus-
tomer address information, 
the data remains the same 
until a user goes into the 
database and changes it. 
If the database tracks the 
total value of a product, the 
value in inventory changes 
when the price changes.

Cell 
E2

 Choose Start>All 

Programs>Microsoft 

Office®>Microsoft Excel 

2010.

 Choose File>Open.

 Locate and open the data 

fi le Product Info.xlsx. 

Save as: Product Info-[your 

first initial and last name] 

(for example, Product Info-

rgupta). 

 Read each fi eld name. Note 

that the fi elds Product ID, 

Product Name, Cost,

and Inventory all contain 

stored data.

 Click in cell E2 in the Total 

Value fi eld (see Figure 1.1). 

 Your screen 

should look like Figure 1.1.

Continued on the next page.
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Step-By-Step EXERCISE 1-1 (Continued)

Defi ne Data Needs
FIGURE 1.2 Stored data in Product Info worksheet

FIGURE 1.3 Calculated data changed

 Change in cell D2 causes 
calculated value in cell E2 to 
change

 Click in cell D2 (see 

Figure 1.2).

 Select 1000. Key: 500. 

Press . 

Your screen 

should look like Figure 1.3. 

Note that the value in cell 

E2 changes to $132,600.

 Save and close the 

Product Info spreadsheet 

and exit Excel.

Continue to the next exercise.

Stored data, such as the 
price of an inventory in an 
automotive parts ware-
house database, must be 
changed manually. Calcu-
lated data depends on 
other data. For example, 
the total value of all gaskets 
held in the ware house’s 
inventory would change if 
either the price of head 
gaskets went up or the 
quantity of gaskets went 
up or down. You can calcu-
late stored data in Excel 
and import it to Access. 
You also can create 
calculated and stored 
data directly in Access.

When you begin to design forms and reports, you will 
choose how to fi nd, display, and edit data from one or 
more tables or queries.
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Step-By-Step EXERCISE 1-2
Defi ne Field Data Types
You can use various data types to organize the data tables in your database. Some data 

is best presented as text, while other data should appear as a number. Sometimes, 

data should be stored as a combination of both, or as one of two values, such as Yes 

or No. A Memo data type, which can store up to 65,535 characters, is best for storing 

large amounts of text data, such as a comment or note about a particular order or 

product. A Currency data type is best for storing monetary values. To ensure that data 

in a fi eld supports searches or meets certain conditions, use a data type that supports 

a conditional expression, or Boolean operator, such as AND, OR, or NOT. One kind 

of Boolean operator is a comparison operator, such as equal, not equal, less than, 

more than, and so on. Common data types that support Boolean operators are shown 

in Table 1.2.

Text Currency 

Number Yes/No

Date/Time AutoNumber

 FIGURE 1.4 Product Info QtyInStock field added to parts database

Data type drop-down arrow

Navigation 
Pane

Product 
Info table

 Click Start>All 

Programs>Microsoft 

Office®>Microsoft 

Access 2010.

 Choose File>Open.

 Navigate to the Phils 

Pick-a-Part.accdb

database fi le. Ask your 

teacher how and where to 

copy the database before 

working in it.

 Select the database fi le and 

click Open.

 In the Navigation Pane, 

right-click the Product Info

table and select Design 

View from the menu.

 In the Field Name column, 

click in the blank cell under 

Cost. Key: QtyInStock. 

Press .

 Click the Data Type drop-

down arrow . From the 

list of data types, select 

Number.

Your screen 

should look like Figure 1.4.

 Under Field Properties, 

click in the Caption box 

and key: Stock Quantity.

 Click Save . Click the 

Cost fi eld and press . 

Change the Data Type to 

Currency.

Continued on the next page.

TABLE 1.2 Common Data Types that Support Boolean Operators 
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Step-By-Step EXERCISE 1-2 (Continued)

Defi ne Field Data Types

FIGURE 1.5 Product Info table in Datasheet View

New field defined 
and added

FIGURE 1.6 Customer Info table in Design View

The data types you assign 
will depend on how you 
want to use the data. A 
Date/Time data type 
stores dates. A Number 
data type performs 
calculations. The Memo 
data type saves notes. To 
ensure that data meets a 
condition, change a fi eld’s 
data type to support 
searches or comparisons. 

 Under Field Properties, 

click in the Format box. 

Choose Currency.

 Click Datasheet View . 

Click Yes to save changes. 

Click Yes again.

Your screen 

should look like Figure 1.5. 

Close the Product Info

table.

 Open the Customer Info 

table in Design View.

 Click in the Notes fi eld 

Data Type box. Click the 

drop-down arrow and 

select Memo.

 Your screen 

should look like Figure 1.6.

 Click Save . Close the 

Customer Info table.

Continue to the next exercise.
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Step-By-Step EXERCISE 1-3
Modify Field Properties
Access allows you to set and modify properties for entire tables and for individual 

fi elds within a table. For example, by specifying the Field Size, or maximum number 

of characters that a user can enter in a fi eld, you can ensure that data in the Phone 

Number fi eld contains ten digits. You also can set a memo fi eld as Append Only. With 

this option, users can add data to a fi eld, but they cannot delete data from it. Common 

properties for fi elds in a table are shown in Table 1.3.

TABLE 1.3 Common Field Properties 

Allow Zero Length
Specifi es that a Text, Memo, or Hyperlink fi eld can accept strings of 
zero length, or null values, with no characters.

Append Only
Specifi es that data can be added to a Memo fi eld, but that the existing 
data in the fi eld cannot be overwritten.

Caption Specifies the name of a Text field.

Field Size Specifi es the maximum number of characters a user can enter in a fi eld.

Required Specifi es that data must be entered in a fi eld.

FIGURE 1.7 Customer Info table edited

Customer Name field

Notes field

 In your Phil’s Pick-a-Part

database, in the Naviga-

tion Pane, double-click 

the Customer Info table.

 Choose Home>Views>

Design View .

 Click the Customer Name

fi eld. In Field Properties, 

click in the Field Size box. 

Key: 80. Press .

 Click the row selector to the 

left of Telephone. While 

still holding the mouse 

button, drag down until the 

bold black line is above the 

Description fi eld.

 Release the mouse. Scroll 

down the fi eld names list 

and click in the Notes fi eld.

 Scroll down the Field

Properties and click in the 

Append Only box.

 Click the drop-down arrow 

and select Yes.

 Your screen 

should look like Figure 1.7.

 Click Save . Close the 

table.

Continue to the next exercise.

Access assigns a default 
fi eld name if you do not 
enter a caption for a fi eld.
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Step-By-Step EXERCISE 1-4
Set Validation Rules
You can use the Validation Rule property to restrict the type and amount of data users 

can enter into a fi eld by creating a Boolean (or conditional) expression in the 

Validation fi eld. Validation rules use conditional expressions to specify that the data 

meets certain criteria. You can use the Validation Text property to customize the error 

message that Access displays when data that is entered into a fi eld violates a validation 

rule. Validation messages should contain information about the invalid data and how 

to fi x the error. Examples of validation rules are shown on page 256 in Table 1.4.

FIGURE 1.8 Customer Info table with validation added

FIGURE 1.9 Customer Info table in Database View

Validation rule Validation text

 In your Phil’s Pick-a-Part

fi le, in the Navigation 

Pane, double-click the 

Customer Info table.

 Choose Home>Views> 

Design View .

 Click in the Account Start 

Date fi eld box. Under 

Field Properties, click in 

the Validation Rule box 

and key: >=#01/01/2011#.

 Click in the Validation 

Text box and key: Date 

entered must be after 

January 1, 2011.

 Your screen 

should look like Figure 1.8.

 Choose Design>Views>

Datasheet View . 

Click Yes to save changes.

Your screen 

should look like Figure 1.9.

 If necessary, in the Data 

Integrity warning box, 

click Yes. 

Continued on the next page.

To delete a fi eld in 
Datasheet View, right-
click on the fi eld’s column 
head and select Delete 
Field.
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Step-By-Step

Invalid start date

EXERCISE 1-4 (Continued)

Set Validation Rules 

 FIGURE 1.10 Validation error dialog box

Validation error dialog box with validation text

TABLE 1.4 Sample Validation Rules 

Validation Rule Description of Rule

>0 Requires users to enter a positive value 

<100 Requires users to enter a value that is less than 100

>100 AND <1000 Requires users to enter a value between 100 and 1,000 

[EndDate]>=[StartDate]
Requires users to enter an ending date that occurs on or after a 
starting date

>=#01/01/2012# Requires users to enter a date on or after January 1, 2012

[RequiredDate]<=[OrderDate]+30
Requires users to enter a date that is no later than 30 days after 
the order date  

 Scroll to the right until you 

can see the Account 

Start Date fi eld.

 Click in the fi rst record 

under the heading.

 Highlight the year 2011 in 

the date and key: 2009.

 Press .

Your screen 

should look like Figure 1.10.

 In the warning dialog box, 

click OK. Highlight the date 

and key: 2011.

 Press .

 Close the table. Click Yes.

Continue to the next exercise.

If you enter data into a fi eld 
that violates a validation 
rule, Access prevents you 
from moving to another 
fi eld until the problem is 
fi xed. The Validation Text 
property tells you how to 
fi x the error.
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Step-By-Step EXERCISE 1-5
Defi ne and Modify Primary Keys
A primary key is a fi eld that ensures that each record in a table is unique. By default, 

Access records in a table are sorted based on the primary key. In the Phil’s Pick-a-Part 

database, for example, the Customer ID acts as a unique identifi er for each customer 

in the database. You can identify each customer uniquely because no two customers 

have the same Customer ID number. A fi eld with the AutoNumber data type is often 

used as the primary key because the numbers assigned to the fi eld increase 

automatically with each new record. Characteristics of a good choice for a primary 

key are shown in Table 1.5.

 FIGURE 1.11 Customer Info table Datasheet View

TABLE 1.5 Choosing a primary key

A good candidate for a primary key…

1. Is a value that uniquely identifi es each record in the table.

2. Is a field that is never empty. It always contains a value.

3. Is a value that does not change.

 In your Phil’s Pick-a-Part

database, open the 

Customer Info table in 

Design View.

 Click the record selector for 

the Customer ID fi eld. 

Choose Design>Tools>

Primary Key .

 Click the record selector for 

the  Customer Name 

fi eld. Choose Design> 

Tools>Primary Key .

 Choose Design>Views>

Datasheet View .

 Click Yes to save the 

changes to the Customer 

Info table.

Your screen 

should look like Figure 1.11.

 Choose Design>Views>

Design View .

 Click Save  and close 

the Customer Info table.

Continue to the next exercise.

Some database fi elds 
would not make a good 
choice for primary keys. 
For example, you may 
have more than one John 
Smith in the Name fi eld. 

Customer Name alphabetized as Primary Key

Customer ID out of sequence when no longer 
set as Primary Key
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Step-By-Step EXERCISE 1-6
Defi ne and Modify Multi-Field Primary Keys
A multi-fi eld primary key is a table with two or more fi elds defi ned as the primary 

key. A multi-fi eld key is used if a table has no single fi eld that is appropriate to serve 

as the primary key. Although a primary key should include as few fi elds as possible, 

if a table has no single fi eld with a set of unique values, two or more fi elds can be 

combined to create a unique value. In this exercise, the Product ID fi eld in the Product 

Info table is not a suitable primary key. Multiple primary keys are assigned to the 

Product Name and Cost fi elds to fi x this problem. Because there are no two products 

with the same name or price in the Phil’s Pick-a-Part database, the multiple primary 

keys assign a unique value to the relationship between these two fi elds.

FIGURE 1.12 Product Info table multiple primary keys

Two Primary Key fields selected

Primary key icon

FIGURE 1.13 Product Info table in Datasheet View

Product Name now determines 
listing order

 In your Phil’s Pick-a-Part

database, open the 

Product Info table in 

Design View.

 Click the record selector for 

the Product Name.

 Hold down  and

click the record selector

for Cost.

 Choose Design>Tools>

Primary Key .

 Your screen 

should look like Figure 1.12.

 Choose Design>Views>

Datasheet View . 

Click Yes.

Your screen 

should look like Figure 1.13.

 Click Design View .

 Click the record selector for 

the Product ID fi eld. Click  

Primary Key .

 Click Close  on the 

Product Info table. Select 

Yes to save changes.

Continue to the next exercise.

A multi-fi eld primary key 
is also referred to as a 
composite key.
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Step-By-Step EXERCISE 1-7
Defi ne Tables in Databases
When you design a database, it should be structured correctly so that the data is 

accurate, easy to work with, and accommodates your needs. When you add new 

tables to any database, analyze your design for errors to see if your tables are 

normalized, or structured correctly without repeated groups of information. A well-

designed database typically contains 3NF tables. A 3NF table is a table that is 

normalized to the third order. This means that they comply with the fi rst three rules 

of normalization. The three rules to create a 3NF table are shown in Table 1.6. The 

rules of form build on the previous rules, so a Third Normal Form table complies 

with all the rules of the fi rst and second forms as well as the third form.

TABLE 1.6 Rules of normalization 

Rule Description of Rule

1NF
Each fi eld in database table contains a single value, and the table has no repeating groups of 
information

2NF
Each non-key field in the table must be dependent on the entire primary key (including multi-field 
primary keys)

3NF Each non-key fi eld in the table is dependent only on the primary key

FIGURE 1.14 New Sales Info table

Table saved as Sales Info

Default Primary Key field

 In your Phil’s Pick-a-Part

database, open the 

Customer Info table.

 Scroll to the right until you 

see the Account 

Manager fi eld. Read the 

Account Managers’ last 

names listed in the 

Customer Info table.

 Close the Customer Info 

table.

 Choose Create>Tables>

Table .

 Choose Datasheet> 

Views>Design View . 

In the Save As dialog box 

key: Sales Info. Click OK.

Your screen 

should look like Figure 1.14.

 Key: Account Manager. 

Press .

Continued on the next page.

Formatting the objects in 
your database can make 
data much more readable. 
Adding a visual element, 
such as a logo, is espe-
cially useful when creating 
forms and reports. Logos 
can make your forms
and reports look more 
professional and visually 
appealing. 
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Step-By-Step

 Click the Data Type drop-

down arrow and select 

Text. Press  twice.

 Key: First Name. Press

.

 Set the Data Type to 

Text. Press  twice.

 Key: Cell Phone. Click in 

the fi eld below Cell 

Phone.

 Key: Employee Number. 

Press .

 Click the drop-down arrow 

and select Number. Press 

 twice.

 Key: Client. Press .

 Click the drop down arrow 

and select Text.

Your screen 

should look like Figure 1.15.

 Choose Design>Views>

Datasheet View . In 

the dialog box, click Yes to 

save changes to the table.

 Key the information into 

the table as it is shown in 

Figure 1.16.

 Click Close  to close 

the Sales Info table. Click 

Yes to save changes to 

table layout, if necessary.

Continue to the next exercise.

FIGURE 1.15 Sales Info table 3NF fields Design View

FIGURE 1.16 Populated Sales Info table in Datasheet View

All fields are dependent 
only on Primary Key

Data Type drop-down arrow

No repeating 
groups

EXERCISE 1-7 (Continued)

Defi ne Tables in Databases
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Step-By-Step EXERCISE 1-8
Create Tables Based on the 
Structure of Other Tables
Rather than using a table template, or taking the time to build a new table for your 

database using Design View or Datasheet View, you can use an existing table’s 

structure to create a new table. You can create a table by copying and pasting the 

structure of an existing table in the Navigation Pane. You can edit the table name 

using the Paste Table As dialog box.

FIGURE 1.17 Paste Options in Paste Table As dialog box

FIGURE 1.18 Table structure copied to Customer Contacts

Structure Only option

New Customer Contacts table

Structure from Sales Info table

To delete a database 
object, such as table, 
select the object in the 
Navigation Pane, right-
click and select Delete.

 In your Phil’s Pick-a-

Part database, in the 

Navigation Pane, right-

click the Sales Info table 

and select Copy.

 Right-click in an open area 

of the Navigation Pane. 

Select Paste. 

 In the Paste Table As 

dialog box, click in the 

Table Name box. Key: 

Customer Contacts.

 Under Paste Options, 

select Structure Only 

(see Figure 1.17). Click OK.

 In the Navigation Pane, 

double-click the Customer 

Contacts table.

Your screen 

should look like Figure 1.18. 

Close the table.

 In the Navigation Pane, 

right-click the Customer 

Contacts table. Select 

Rename.

 Key: Quick Customer 

Contacts. Press .

Continue to the next exercise.
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Step-By-Step EXERCISE 1-9
Create and Modify Queries
A query gathers data from one or more tables based on criteria. Queries allow you to 

retrieve and display information from tables so that you can edit the results. A query is 

made up of the fi elds and records you add, remove, and rearrange in the order you want. 

If two or more tables have fi elds with the same name, you must identify which table you 

want the query to draw from. The information you need to provide to run a query is:

1. the criteria that you want the data to meet

2. the fi elds that you want to include

3. the tables from which you will retrieve the data

 FIGURE 1.19 Simple Query Wizard

Query Wizard button

 In your Phil’s Pick-a-Part

fi le, choose Create> 

Queries>Query Wizard

 (see Figure 1.19).

 In the New Query dialog 

box, make sure the Simple 

Query Wizard option is 

selected. Click OK.

 In the Simple Query 

Wizard dialog box, under 

Tables/Queries, click the 

drop-down arrow and 

select Table: Sales Info.

 Under Available Fields, 

click the double right arrow 

 to select all fi elds in 

the Sales Info table.

 Your dialog 

box should look like 

Figure 1.20.

 Click Next. Leave the 

Detail option selected and 

click Next.

 Do not change the title for 

your query. Click Finish.

Continued on the next page.

To view the results of a 
query, choose Design>
Results>Run or switch to 
Datasheet View.

All fields in 
table added

FIGURE 1.20 Simple Query Wizard with all Sales Info table fields selected
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Step-By-Step EXERCISE 1-9 (Continued)

Create and Modify Queries
 Choose Home>Views>

Design View .

 Your screen 

should look like Figure 1.21.

 Choose Design>Query 

Setup>Show Table .

 In the Show Table dialog 

box, select the Customer 

Info table and click Add.

 Click Add again.

 Your screen 

should look like Figure 1.22.

 Close the Show Table

dialog box. Right-click the 

header of the Customer 

Info_1 table and select 

Remove Table.

Continued on the next page.

FIGURE 1.21 Sales Info Query in Design View

FIGURE 1.22 Sales Info Query with duplicate tables added

Duplicate Customer Info table

Asterisk field adds entire 
table to field list area

Field list area

Show field check box

Another way to add all the 
fi elds from a table to query 
is to open the query in 
Design View. Then, 
double-click the asterisk 
(*) at the top of the list of 
fi elds in the query.

To remove a fi eld from a 
query, select the fi eld in 
the fi eld list area, right-
click and select Cut.
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To rearrange fi elds, select 
the fi eld that you want to 
move in the fi eld list pane 
and click and drag the 
fi eld to the right or left.

Step-By-Step EXERCISE 1-9 (Continued)

Create and Modify Queries

FIGURE 1.23 Sales Info Query in Datasheet View

FIGURE 1.24 Query with duplicate field drawn from single table

Same field from two different tables

 In the Sales Info Query, 

click the Customer Info 

table. Scroll through the 

fi eld list and double-click 

the Account Manager

fi eld.

 Scroll to the top of the 

table and double-click the 

Customer Name fi eld.

 Choose Design>Results>

Datasheet View .

 Your screen 

should look like Figure 1.23.

  Click Design View .

 In the fi eld list area, under 

the Account Manager 

fi eld of the Customer Info 

table, uncheck the box in 

the Show fi eld.

 Click Datasheet View .

Your screen 

should look like Figure 1.24.

 Click Save . Close the 

Sales Info Query.

 Click the File tab and 

select Close Database.

Continue to the next exercise.

Advanced Access 264Lesson 1: Exercise 1-9

260-269_iCkA_U03_L01_661409.indd Page 264  5/3/11  8:30 PM s-60user260-269_iCkA_U03_L01_661409.indd Page 264  5/3/11  8:30 PM s-60user /Volumes/103/GO00827/i-CHECK_2012/ANCILLARY/MS_OFFICE_ADVANCED_EXERCISE.../Volumes/103/GO00827/i-CHECK_2012/ANCILLARY/MS_OFFICE_ADVANCED_EXERCISE.

  PDF Pass  



Press  +  to 
display the Open dialog 
box.

To confi gure Access to 
open the last used database 
when Access starts, 
choose File>Options>
Advanced and click Open 
last used database when 
Access starts.

Step-By-Step
EXERCISE 1-10
Open Databases
When you open a database in Access, by default it can still be opened and edited by 

others at the same time. This is called shared access. If you need to ensure that you are 

the only one who can open and make changes to the database, you can select the Open 

Exclusive option in the Open dialog box or set the Default open mode to Exclusive 

using the Access Options dialog box. That means that no one else can open or edit the 

database because you have exclusive access. Access also offers an Open Exclusive Read 

Only option so that you and other users can view the database at the same time but 

cannot edit it. This read-only mode is helpful in a multi-user environment if you want 

to view a fi le but want to avoid making any accidental changes.

FIGURE 1.25 Open dialog box

FIGURE 1.26 Database opened exclusive read-only

Open button drop-down menu

Database file selected

Read-Only message

 Click File. Click Open.

 In the Open dialog box, 

navigate to your Phil’s 

Pick-a-Part fi le. Select the 

database fi le and click the 

Open drop-down arrow.

Your dialog 

box should look similar to 

Figure 1.25. Select Open 

Exclusive.

 Click the File tab and 

select Close Database.

 Choose File>Open. Select 

the database fi le again and 

click the Open drop-down 

arrow. Select Open 

Exclusive Read-Only.

 Your screen 

should look like Figure 1.26.

 Click  the File tab and 

close the database.

Continue to the next exercise.
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Step-By-Step

FIGURE 1.27 All Orders Chart

FIGURE 1.28 Chart type to 3D Bar Clustered

Change Chart 
Type buttonNavigation Bar

Properties dialog box

3D Bar Clustered

Click this bar
Chart background

EXERCISE 1-11
Format and Modify a Chart
Access offers many tools to format and present data. You can reformat the font in a 

form, apply a background image to a report, add Quick Styles to controls, or apply 

conditional formatting in a form. However, often one of the easiest and most effective 

ways to present data is through the use of charts. Depending upon the type of data 

and your audience, the same data can be presented in several different chart formats. 

Access allows you to easily change the format and type of a chart to improve  the 

presentation of your data.

 Choose File>Open. Select 

your Phil’s Pick-a-Part 

database. Click Open.

 In the Navigation Pane, 

click the Navigation Bar. 

Under Filter By Group, 

select Forms.

 Double-click the All 

Orders Chart form. 

Choose Design>Tools> 

Property Sheet. With the 

General tab selected, 

click Quantity (to the right 

of Years) on the chart 

space. Click Delete in the 

Properties dialog box. 

Close the dialog box.

 Your screen 

should look like Figure 1.27.

 Choose Design>Type>

Change Chart Type .

 In the dialog box, on the 

Type tab in the left column, 

select Bar. Click the 3D 

Bar Clustered chart type 

(see Figure 1.28).

 Click the largest graphed 

quantity on the chart (see 

Figure 1.28). In the 

Properties dialog box, 

click the Border/Fill tab.

 Under Fill, in the Fill Type 

box, select Gradient. Click 

the Border Color drop-

down arrow. Select White.

Continued on the next page.
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Step-By-Step EXERCISE 1-11 (Continued)

Format and Modify a Chart
 Click in an open area of the 

chart space to select the 

chart background.

 In the Properties box, 

under Fill, click the Color 

drop-down arrow and 

select MediumSeaGreen.

 In the Properties box, click 

the Show/Hide tab. Under 

Show by default, uncheck 

the Field buttons/drop 

zones option.

 Your screen 

should look similar to 

Figure 1.29.

 In the Properties box, click 

the General tab. Under 

Add, click Add Title .

 Click Chart Workspace 

Title in the chart window. 

In the Properties box, 

click the Format tab.

 In the Caption box, 

highlight the default text 

and key: Parts Purchases 

by Volume.

 Choose Design>Tools>

Property Sheet .

Your screen 

should look similar to 

Figure 1.30.

 Close the All Orders 

Chart.

Continue to the next exercise.

FIGURE 1.29 Changes to chart formatting

FIGURE 1.30 Title added to chart
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Step-By-Step  EXERCISE 1-12
Import and Export Data
You can gather and present different types of information in Access by importing the 

data. You can import Excel fi les, XML Paper Specifi cation (XPS) fi les, and Access 

databases. You also can import data from ordinary text fi les, as long as the information 

is delimited. A delimited fi le is a fi le that uses delimiters, or separators, such as  

semicolons, colons, or tabs to separate information. An example of a delimited fi le is 

a comma-separated values (CSV) fi le. Access allows you to export data in a database 

fi le to many different fi les, programs, or databases. Access also allows you import and 

append records to an existing table and import data as a linked table.

FIGURE 1.31 Importing a CSV file

FIGURE 1.32 CSV data imported into Quick Customer Contacts

Text File 
import button

Append a 
copy option

Data from CSV file entered into empty table

 In your Phil’s Pick-a-Part

database, in the Navigation 

Pane, show Tables.

 Choose External Data>

Import>Text File .

 Select the Append a copy 

of the records to the 

table: option. Click the 

drop-down arrow. Select 

the Quick Customer 

Contacts table.

Your screen 

should look similar to 

Figure 1.31.

 Click the Browse button. 

In the File Open dialog 

box, navigate to and select 

the Customer Contacts.

txt data fi le. Click Open.

 In the Get External Data – 

Text File dialog box, click 

OK. Click Next twice. Click 

Finish. Click Close.

 Double-click the Quick 

Customer Contacts 

table.

 Your screen 

should look like Figure 1.32.

Continued on the next page.
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Step-By-Step

Attachment field

Double-click 
attachment

 EXERCISE 1-12 (Continued)

Import and Export Data

FIGURE 1.33 Customer Info table attachment

FIGURE 1.34 Saving Object As XPS file

To export an attachment 
to a record in a database 
table, use the Save 
Object As command.

PDF or XPS option

If you want to keep a fi le in 
its original format, you can 
link to it or attach the fi le to 
the database. 

First record 
attachment

 Close the Quick 

Customer Contacts 

table.

 Open the Customer Info 

table and scroll to the last 

column on the right.

 In the Attachment fi eld, in 

the fi rst record, double-

click the attachment (see 

Figure 1.33).

 In the Attachments

dialog box, select the listed 

attachment and click Save 

As. Save the attachment in 

the location specifi ed by 

your teacher. Click OK.

 Choose File>Save & 

Publish>Save Object 

As>PDF or XPS. Click 

Save As (see Figure 1.34). 

Click the Save as type

drop-down arrow. Select 

XPS Document (*.xps).

Continued on the next page.
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Advanced Access 270Lesson 1: Exercise 1-12

Step-By-Step

FIGURE 1.35 Publish as PDF or XPS dialog box

Saving Customer Info as XPS

 Document displayed in XPS Viewer

 In the Publish as XPS

dialog box, navigate to the 

location given by your 

teacher. 

 Select the Open file

after publishing 

option and click Publish

(see Figure 1.35).

Your screen 

should look like Figure 1.36.

 Close the application 

displaying the XPS 

document. Close the 

Customer Info table.

Continue to the next exercise.
Publish button

FIGURE 1.36 Published XPS file opened in XPS Viewer

To save or publish a data-
base object as an XPS 
document or PDF fi le, 
choose External Data> 
Export>PDF or XPS. To 
save or publish a copy of 
the database object as a 
PDF or XPS fi le, choose 
File>Save & Publish> 
Save Object As>PDF or 
XPS.

Open file option

When creating and 
designing forms, create a 
hyperlink to a fi le, a Web 
page, a picture, an e-mail 
address or another 
program by choosing 
Design>Controls>
Hyperlink.

 EXERCISE 1-12 (Continued)

Import and Export Data
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Step-By-Step  EXERCISE 1-13
Set Printing Options
Sometimes you might want to make sure that the data in a report is kept together to 

avoid excess pages and to improve the overall appearance of the report. Print Preview 

lets you review each page and helps you make sure that text and fi elds are correctly 

placed and formatted. Layout View allows you to manipulate fi elds and groups, but 

it does not show page breaks or certain other elements. Access also lets you use the 

Keep Groups Together property to keep data together so that a portion of a record 

does not display on one printed page with the remainder on the next. You can use the 

Force New Page property to print a section of data on a separate page.

FIGURE 1.37 All Orders report Layout View

FIGURE 1.38 All Orders report Print Preview

 In your Phil’s Pick-a-Part

database, in the Navigation 

Pane, click the Navigation 

Bar and select Reports.

 Open the All Orders

report.

 Choose Home>Views>

Layout View .

 Scroll to the end of the 

report.

Your screen 

should look like Figure 1.37.

 Select Home>Views and 

click the View drop-down 

arrow. Select Print 

Preview .

 Choose Print Preview> 

Zoom>Two Pages .

Your screen 

should look like Figure 1.38.

Continued on the next page.

Layout View shows fit on one page

View drop-
down arrow

Broken grouping over two pages

Close Print Preview

Print Preview shows 
two pages at a time

You can also use a Page 
Break control to mark 
where you want to start a 
new page within a section 
when designing your 
reports. To insert a page 
break control, open the 
report in Design view, 
choose Design>Controls>
Insert Page Break and 
click where you want to 
insert the page break.
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Step-By-Step  EXERCISE 1-13 (Continued)

Set Printing Options 
 FIGURE 1.39 All Orders report with Force New Page After Section

Sections broken onto individual pages

 FIGURE 1.40 Grouping and Sorting window

Group & Sort button

Click to expand options

Sorting windowTo add a background 
image to a report using 
the Report Layout Tools, 
choose Format>
Background>
Background Image.

 Close Print Preview. 

Choose Home>Views> 

Layout View .  

 Choose Design>Tools> 

Property Sheet . 

Under Selection type, 

click the drop-down arrow. 

Select Detail. On the 

Format tab, click the 

Force New Page box. 

Select After Section.

 Right-click in an open area 

and select Print Preview.

 Your screen 

should look like Figure 1.39. 

Close Print Preview.

 In the Property Sheet, 

under Selection type, 

click the drop-down arrow. 

Select Detail. Click in the 

Force New Page box. 

Select None.

Close the Property 

Sheet. Choose Design>

Grouping & Totals>

Group & Sort .

Your screen 

should look like Figure 1.40.

Continued on the next page.
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Step-By-Step  EXERCISE 1-13 (Continued)

Set Printing Options
 FIGURE 1.41 Grouping sections together on same page

Groups are kept on same page

 FIGURE 1.42 All Orders report with logo and grouped in sections Print Preview

Groups are not broken over pages

 In the Group, Sort, and 

Total window on the 

Group on Customer 

Name bar, click More.

 Click the do not keep 

group together on one 

page drop-down arrow 

and select keep whole 

group together on one 

page.

Your screen 

should look like Figure 1.41.

 Choose Design> 

Grouping & Totals> 

Group & Sort  to close 

the window.

 Choose Design>Header/

Footer>Logo. Navigate to 

and select the car.jpg data 

fi le. Click OK.

 Choose Design> 

Controls>More. Click 

Insert Hyperlink. Click 

slightly to the right of the 

Product ID header (when 

you see the yellow line). 

 Navigate to your Product 

Info fi le and click OK. 

Choose Design>Views 

View>Print Preview .

 Your screen 

should look like Figure 1.42. 

Close the report. Click Yes 

to save the changes. Close 

your database. Exit 

Access.
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Step-By-Step EXERCISE 1–14
View Code and Convert Macros to
Visual Basic
If you fi nd that you regularly perform the same series of actions, or use the same 

functionality for controls, such as command buttons or text boxes, in your databases, 

you can create a macro to speed up your work.  A macro is an action or sequence of 

actions that you record and then play back with a single command, a click of a 

mouse, opening a form, or modifying data in a text box, for example. Macros allow 

you to improve effi ciency because they are an easy way to automate programming 

tasks and add functionality to your forms, reports, and controls without writing code 

in a Visual Basic editor. Visual Basic (or VBA) is an event-driven programming 

language that allows you to perform much more complex operations and applications 

in Access. In this exercise, you are going to create a macro that will automatically 

maximize the application window and open a particular report every time your 

database opens, view code, and convert macros to Visual Basic.

 In your Phil’s Pick-a-Part 

database, choose Create>

Macros & Code>Macros.

 Under Macro1, in the Add 

New Action drop-down 

list, select Maximize 

Window.

 Click the Add New Action 

drop-down arrow again and 

select OpenReport. In the 

Report Name box, key: All 

Orders. Your screen should 

look like Figure 1.43. 

 Click Save. In the Save As 

dialog box, key: AutoExec. 

Click OK.

 Click Run. Your screen 

should look like Figure 1.44. 

 In the Navigation Pane, 

click the Reports drop-

down arrow and select All 

Access Objects.

 Under Macros, select the 

AutoExec Macro. Switch 

to Design View.

Continued on the next page.

 FIGURE 1.43 Selecting actions in Macro Builder

FIGURE 1.44 Window maximized and All Orders Report opened

Maximize Window action
OpenReport 
action

If you cannot fi nd the 
action you want, choose 
Design>Show/Hide and 
make sure Show All 
Actions is selected. 
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Step-By-Step

 Choose Design>Tools>

Convert Report’s Macros 

to Visual Basic (See 

Figure 1.45). Click Convert.

Click OK. The Visual Basic

Editor opens. 

 In the Visual Basic 

Editor, if necessary, 

choose View>Project 

Explorer to open the 

Project Explorer pane.

 Expand each item on the 

tree under the Phil’s Pick-

a-Part database. Under 

Modules, double-click the 

Converted Macro-

AutoExec.

 Close the Visual Basic 

Editor. In the Navigation 

Pane, under Modules, 

select Converted Macro-

AutoExec.

 Choose Design>Tools>

View Code.

 You screen should look like 

Figure 1.42. Close the 

Visual Basic Editor.

 Save and close your 

database.

Continue to the next exercise. 

EXERCISE 1–14 (Continued)

View Code and Convert Macros to
Visual Basic
FIGURE 1.45 Converting report’s AutoExec macro to Visual Basic Editor

FIGURE 1.46 Code for converted macro viewed in Visual Basic

View code

Convert macros to 
Visual Basic

AutoExec macro

If you do not want an 
AutoExec macro to run 
when opening a database, 
hold down   while you 
open the database.
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Step-By-Step

Lesson 1: Exercise 1-15

EXERCISE 1–15
Modify Forms and Reports
Before you print out a form or report, you may decide that you want to change its 

layout to better organize its information. The simplest way to make changes to a form 

or report to make it more readable is to use the Design Tools in Design View. The 

layout of a form or report is similar to a table in a word processing document in that 

it is made up of cells that are arranged in rows and columns. You may decide that you 

want to add, rearrange, or remove controls from the page layout using the Table 

group on the Arrange tab, apply Quick Styles to a command button, change the tab 

order of controls, or align the output to a grid. You may also want to rearrange, or 

move, a table cell to a new location in the layout, or change a button’s shape. In this 

exercise, you will make changes to the design and layout of the All Orders report. You 

will also create and format a command button for a form that you plan to use at a 

future date.

 In your Phil’s Pick-a-Part 

database, choose 

Home>Views>Design 

View.

 Choose Design 

Tools>Tab Order. The Tab 

Order dialog box opens. 

Under Custom Order, 

click and drag Date below 

Product ID and Quantity 

in the list (see Figure 1.47). 

Click OK.

 Click the Arrange tab. In 

the All Orders table layout, 

select the cell that contains 

the hyperlink to the 

Product Info table.

 Choose Arrange>Move>

Move Up. The cell 

containing a hyperlink 

moves up in the table 

layout.

 With the cell still selected, 

choose Arrange Format>

Sizing & Ordering>Align 

and click To Grid. Your 

screen should look like 

Figure 1.48.

 Choose Design>

Controls>Button. Click 

just to the right of the 

hyperlink. With the button 

still selected, choose 

Format>Control 

Formatting>Change 

Shape. Click Oval.

Continued on the next page. 

FIGURE 1.47 Tab Order dialog box

 FIGURE 1.48 Hyperlink moved to another table cell in report design layout

Date moved below Product ID and Quantity 
in Tab Order list

Align

Move group
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Step-By-Step

 Choose Format>Control 

Formatting>Quick Styles 

and select the fourth button 

in the last row.

 Click inside the button and 

change the button’s text to 

All Orders. Press . See 

Figure 1.49. 

 Right-click on the button 

and select Delete.

 Close the All Orders 

Report and click Yes to 

save the changes.

 In the Navigation Pane, 

select All Orders Report

and choose Create>

Forms>Form Design. 

Repeat steps 6 and 7 to 

create and format a similar 

button called Next.

 In the Command Button 

Wizard, click Next. Select 

Text. In the Text box, key 

Next. Click Finish.

 Apply the same shape and 

Quick Style. Click anywhere 

on the form’s table grid (see 

Figure 1.49).

 Save the form as: Next 

button.

 With your teacher’s 

permission, choose 

File>Print to print the 

modifi ed All Orders Report. 

 Save and close your 

database.

EXERCISE 1-15 (Continued)

Modify Forms and Reports

 FIGURE 1.49 Command button’s shape and style changed

 FIGURE 1.50 New shape and Quick Style applied to command button for a form

Oval shape

If you want to move the content of a table’s cells in a 
form layout, open the form in Design View and choose 
Arrange>Move and select Move Up or Move Down.

To change a command button’s shape in a form or report, 
choose Format>Control Formatting>Change Shape.
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